Widget error: 'These metrics and filters are not compatible'

Choosing a metric and a filter or a metric and a time-period that aren't compatible with each other will result in this error message: These metrics and filters are not compatible. Please change your query.

Widget_Error.jpg

The data sources we integrate with might not support every combination of metric, filter or time-period. We try to hide configuration options that can't be used, but that isn't always possible.

Was this article helpful?

Awesome! 👍 Thanks so much for your feedback!

Sorry about that! Start a conversation now.

Ready to create your own dashboard?

Get started for free

Still have questions? Get in touch.